Doymer Consultores

  • Increase font size
  • Default font size
  • Decrease font size
Inicio Blog Varios ADSL2+, Annex-M...¿Se está quedando tu Cisco obsoleto?
01
Agosto
2010

ADSL2+, Annex-M...¿Se está quedando tu Cisco obsoleto?

Imprimir PDF

Conforme avanza la tecnología los usuarios van exigiendo mayores prestaciones a los sistemas instalados. Esta tendencia también se aplica a las velocidades de las conexiones ADSL donde los circuitos se estan llevando a los llímites. Cuando hace relativamente poco la velocidad máxima eran 10Mbps ahora tenemos 20Mbps y lo mismo ocurre para la velocidad de subida; antes nos conformabamos con 1 mega mientras que ahora nos están ofreciendo circuitos de hasta dos megas y medio (2,5 Mbps).

Sin embargo todo esto lo es a un coste y es la necesidad de actualizar los routers que gestionan estos circuitos. Habitualmente el operador suministra un equipo adecuado al tipo de conexión que nos ofrece pero, ¿qué pasa si el router que estamos usando no es el del operador sino uno propio?. Es habitual haber sustituido el router simple y sin demasiadas prestaciones que nos suministró el operador por un router propio –habitualmente de marca cisco– que nos permitió tener servicios adicionales e incrementar la seguridad de nuestra red; ¿ha llegado su San Martín?¿hemos de tirarlo?

Renovarse o morir dice el refrán. Y, aunque eso suele ser lo habitual, en este caso vamos a mostrar una alternativa que nos permitirá alargar la vida de este equipo hasta que reunamos el dinero necesario para actualizarlo.

 

Demos la bienvenida a los 20Megas

Por lo que hemos visto en los foros es bastante habitual tener un cisco 857 u cisco 877 como equipo de acceso a internet. Estos equipos fueron diseñados por cisco para el mercado SOHO a un precio asequible y son ya viejos compañeros para muchos. El problema es que esos routers no son configurables: el modelo adquirido determina las capacidades del mismo y para los modelos indicados los límites estan marcados en 10Mbps de bajada y 1Mbps de subida.

NOTA: Como ya ha indicado un usuario el cisco 857 no es un equipo válido ya que no admite más que una única VLAN, la 1 que ya viene definida por defecto. Otros routers que pueden servir, aunque no inicialmente orientados para el mercado SOHO pero que por su obsolescencia pueden adquirirse a buen precio en el mercado de segunda mano, son los de la serie 17xx como el 1711 o el 1721. Para saber qué modelos admiten esta característica podemos ir a la página de Selección de Características de Cisco, marcar 'IEE 802.1Q VLAN Support' y pulsar el botón de continuar. En la parte inferior aparecerán todos los modelos que soportan esta opción en la pestaña 'Platform'.

En muchos casos los operadores están actualizando su infraestructura y pasando los antiguos circuitos de 10Mbps a  los nuevos de 20Megas. Se supone que antes de realizar un cambio de este tipo se han puesto en contacto con el cliente y le han avisado. También se supone que le han mandado un kit de conexión nuevo que incluye un router ADSL2+ pero sabemos que hay casos en los que tal comunicación no ha existido y el usuario se ha encontrado de un día para el siguiente sin acceso a internet y, aunque tal comunicación se haya producido, el día del cambio de tecnología el cisco deja de funcionar.

Superando los límites: Annex-M

Otras veces recibimos una llamada ofreciendonos mejorar la comunicación: "La cobertura de su zona ha mejorado" te dicen al teléfono, y te ofrecen una velocidad de subida de 2,5 Megas sin limitaciones. Pero claro, para poder llegar a esta velocidad tienes que activar un modo especial llamado Annex-M y resulta que tu router no lo tiene. Conclusión, tienes que renunciar a esa solución o a tu router actual.

La solución

Antes de empezar a pensar en triturar nuestro router en una batidora como es habitual en algunas páginas de internet podemos intentar una forma alternativa de conexión que nos permita mantener lo mejor de ambos mundos. La solución propuesta es la presentada en el siguiente esquema:

bridge_adslEs decir, el nuevo circuito ADSL2+ llega al nuevo router que el proveedor del servicio nos ha entregado garantizando así que la línea se va a activar correctamente.

Sin embargo nosotros vamos a modificar levemente la configuración del nuevo router para hacer nuestro truco. Gracias a la racanería de los proveedores de servicio que cuando el ADSL empezó a extenderse te conectaban tu ordenador directamente a la red en una configuración que llamaban 'monopuesto', evitando que pudieras tener varios equipos de casa compartiendo la línea (si querías esa posibilidad tenías que pagarla aparte), todos los routers que ofrecen los operadores en la actualidad tienen un modo de funcionamiento en bridge del que nos vamos a aprovechar. Y si no la tienen todos al menos si los que hemos podido probar así que es probable que el vuestro también la tenga.

El modo bridge permite que el router sea 'transparente' en cuanto a la red se refiere y nosotros vamos a recibir en nuestro router cisco todo el tráfico como si éste estuviera directamente conectado a la línea. En este sentido vamos a hacer que el cisco se comporte como si fuera un PC de cara al operador salvo para la capa más baja de la conexión que es justo lo que estamos buscando.

Así que, partiendo de la configuración 'oficial' que nos suministra el proveedor, tomamos un cable de red estándar y conectamos una de las salidas del router que hemos recibido –por ejemplo la LAN2x– con una de las conexiones de red de nuestro router cisco. Como, probablemente, ya estemos usando el interfaz FE0 con la conexión del resto de nuestra red podemos usar FE3.

Ya tenemos establecido el circuito físico. Ahora tenemos que hacer dos cosas:

  1. Configurar el router del proveedor en modo bridge
  2. Configurar el cisco para que negocie la conexión con el proveedor en el interfaz FE3

Configurando el modo bridge

Un aspecto que es evidente aunque no lo hayamos expresado con anterioridad es que necesitamos tener acceso a la configuración del router del proveedor. Esto es algo que hace ya bastante tiempo que los proveedores permiten de forma habitual y ahora no hay que estar peleando con ellos para conseguirlo. Son habituales el par 1234/1234 y admin/admin como usuario y contraseña. Si tu router no responde a ninguna de ellas entonces busca en internet o pregúntale a tu proveedor.

Es evidente que hay amplísimo abanico de posibilidades en cuanto a la marca y modelo de router suministrado pero el Comtrend 5361 es uno de los más comunmente instalados con los nuevos circuitos por lo que será sobre éste sobre el que centraremos las indicaciones. Las instrucciones que damos deben usarse sólo como guía si tu modelo de router no es el mismo que el presentado.

La ppuertos_redarte posterior del router ofrece las conexiones que se muestran en la foto de la izquierda. Este router puede venir en varias modalidades una de ellas con 2 de los 4 puertos disponibles reservados para la televisión IP (el etiquetado IPTV) y para la telefonía IP (el etiquetado HG). Si este es el modelo que se posee estos dos puertos son los números 3 y 4 en la configuración interna del router y no debemos tocarlos. De hecho sólo tocaremos la configuración del puerto que vayamos a conectar con nuestro router cisco para tener la garantía de que a través del otro puerto se puede seguir navegando por internet y de esta forma salir al paso de las preguntas que el proveedor pueda hacernos si, o cuando, haya algún problema con la línea evitando invalidar el soporte técnico (se agarran a un clavo ardiendo). Así, si enchufas un equipo al puerto LAN1x (no el router cisco sino tu PC), tendrás el acceso a internet que por defecto te instalan y podrás contestar todas las preguntas que te hagan sin tener que inventarte las respuestas.

Tras acceder a la consola del router seleccionamos la pestaña 'Advanced Setup' y nos aparecerá una pantalla como esta :

captura_1

En ella debieramos tener dos interfaces, uno de ellos el que nos conecta con el proveedor (el llamado pppoe_8_35_2 en nuestra captura) y otro llamado nas_8_35 o algo similar. Lo más importante es el protocolo: para el primero que hemos dicho éste es PPPoE mientras que el segundo es de tipo Bridge. Si no tienen ningún interfaz de este tipo configurado en tu router habrá que dar uno de alta. Usa para ello el botón 'Add' que hay en la base de la tabla y puedes utilizar las siguientes pantallas como guía:

if_bridge1if_bridge2if_bridge3

Cuando tengamos definido este interfaz podemos efectuar la asignación que buscamos. Para ello vamos a la entrada 'Port Mapping' de la pestaña 'Advanced Setup' donde tendremos un grupo base llamado 'Default' que es donde acaban todos los puertos que no están asignados a otro grupo específico. En nuestro router tenemos lo siguiente:

port_mapping

 

Podemos ver que los interfaces LAN1x, LAN2x (llamados ENET1 y ENET2 en las pantallas de configuración) están asignados al grupo por defecto mientras que los otros dos (ENET3 y ENET4) lo están a un grupo especial llamado Bridge.

¿Por qué digo que es un grupo especial? Porque uno de los interfaces pertenecientes a este grupo es el llamado 'nas_8_35' que, si recordamos, tenía un protocolo de tipo Bridge.

Si tu router no incluye este grupo debes crearlo y asignar, al menos, los interfaces LAN2x (o el que hayas usado para conectar con el cisco) y 'nas_8_35'. Nuestro objetivo es incluir el interfaz de red en el que hemos conectado nuestro cisco en este grupo.

Para ello pulsamos el botón 'Edit' (o el botón 'Add' si no existía con anterioridad) y entramos en el modo de configuración de grupos de interfaces.

port_mapping1El funcionamiento de esta pantalla es el tradicional. Seleccionamos los interfaces deseados de la lista de la derecha (de 'Available Interfaces' o Interfaces Disponibles) y los pasamos a la lista de la izquierda ('Grouped Interfaces' o Interfaces Agrupados) con el botón que contiene la flecha con la dirección deseada. Al final, como mínimo, tendríamos que tener los dos interfaces anteriormente indicados en la lista de la izquierda. En nuestro caso ya teníamos dos y ahora hemos añadido el nuestro.

Una vez que la lista está como queremos la salvamos poniéndole el nombre que queramos si la estamos creando en lugar de editando la existente.

Al final nos quedarán dos grupos con los interfaces distribuidos como queremos.

port_mapping2

annex_mComo nota final indicar que si estas contratando la configuración de alta velocidad de Jazztel es necesario tener en cuenta un pequeño detalle. Los routers que envían no están configurados para funcionar a la velocidad máxima posible. Para ello tienes que ir a la opción 'DSL' de la pestaña 'Advanced Setup' y DESMARCAR la casilla 'AnnexM DISABLED' que, como hemos dicho, viene activada por defecto (deshabilitando la alta velocidad como consecuencia). Además es posible que tengas que efectuar una llamada al soporte técnico para pedirles que activen el modo AnnexM. En mi caso tuve que hacerlo. En el tuyo verifica primero si ya está activado y así evitas que te saquen los colores.

Para ver si te están sincronizando a la máxima velocidad sólo tienes que ir a la opción 'ADSL' de la pestaña 'Device Info' y ver qué ponen los campos 'Attainable Rate (Kbps)' y 'Rate (Kbps)' tanto en bajada (Downstream) como en subida (Upstream). Si el AnnexM está activado la subida deberá ser estar más cerca de los dos megas que del mega dependiendo el valor final de la distancia a la que te encuentras de la central de zona (esto ya es como siempre).

 

Configurando el interfaz FE4

Ahora viene lo divertido. Ya debiéramos estar recibiendo tramas en el interfaz de nuestro cisco. Sólo tenemos que iniciar la secuencia correcta de comandos para establecer la conexión de las capas superiores del protocolo. A estos efectos vamos a considerar que la conexión se establece mediante PPPoE que es la más habitual de las posibles y la que están configurando con más frecuencia los proveedores de ADSL en estos momentos (como pudísteis ver en la pantalla inicial del Comtrend).

NOTA: Como antes estoy hablando de los proveedores de mi país, España. Los lectores de otros países tendrán que considerar el tipo de servicio que les ofrecen sus respectivos proveedores aunque hay muchas posibilidades de que sea el mismo puesto que los proveedores de DSLAMs son los mismos en todas partes. Aún así, como es evidente, no puedo ofrecer configuraciones para estos casos.

Lo primero que tenemos que hacer es separar el circuito de conexión al router del proveedor del circuito de conexión a nuestra red interior. En un router habitualmente todos los puertos físicos pertenecen por defecto a la VLAN 1. Por ello lo primero será definir una VLAN para la comunicación con el router del proveedor. Luego asignaremos el interfaz deseado a esa VLAN. Para ello entramos en el cisco y pasamos al modo enabled si no lo estamos. Emitimos entonces estas líneas sin entrar en modo configuración (directamente desde el modo enabled):

vlan database
vlan10 name <el nombre que quieras>
apply
exit

Puedes ignorar la advertencia que da; por el momento sigue funcionando de esta forma así que la usaremos para definir la VLAN. El resto de comandos ya si que van en modo configuración. Lo siguiente es asignar el interfaz que va al Comtrend a la VLAN que acabamos de crear:

interface FastEthernet3
switchport access vlan 10
spanning-tree portfast
exit

Ahora podemos apagar el interfaz ATM; ya no va a ser usado por lo que es innecesario tenerlo activo:

interface ATM0
shutdown
exit

A continuación definimos los parámetros de nuestra nueva VLAN10 necesarios para la comunicación a establecer.

bba-group pppoe global
interface Vlan10
ip address dhcp
pppoe enable group global
pppoe-client dial-pool-number 1
exit

Estas líneas definen tanto el tipo de conexión como la forma de obtener el gateway por defecto cuando la comunicación se establezca y utilizan el mecanismo más habitual en el momento actual que es el de asignación directa por parte del proveedor. Tenemos también que definir un interfaz ppp con el que vamos a efectuar la llamada:

interface Dialer0
ip address negotiated
ip mtu 1492
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer-group 1
no cdp enable
ppp authentication chap callin
ppp chap hostname <tu usuario>
ppp chap password <tu contraseña>
exit

Podemos apreciar que aquí también indicamos que la IP la asigna el proveedor a través de sus propios medios (ya sea fija o dinámica) y que el interfaz debe ser considerado 'outside', es decir que la configuración de NAT se aplique sobre el considerandolo como externo. Por supuesto hay que incluir el nombre y la contraseña que te haya dado tu proveedor y adaptar el tipo de autentificación si la que se usa no es chap (la otra es pap pero como es bastante insegura no suele usarse hoy día). Finalmente es muy importante el asignar una MTU correcta como ya se explicó en un artículo anterior.

En la configuración anterior hemos eliminado otras opciones necesarias en un interfaz externo como son listas de control de acceso, monitorización de tráfico, etc. limitando el listado a aquellas que nos interesan en este caso. Para completar la configuración consideramos otros detalles para que todas las piezas definidas encajen y se comuniquen unas con otras como los siguientes:

ip route 0.0.0.0 0.0.0.0 Dialer0 ! Puede omitirse si la asignación de gateway esta incluida
ip nat inside source route-map noNAT interface Dialer0 overload ! cambio de circuito
access-list 1 permit <dirección de la red interior>
dialer-list 1 protocol ip permit

Y esto es todo. Si lo hemos hecho bien (y yo no me he olvidado de nada) el router comenzará a emitir llamadas PADI (PPPoE Active Discovery)extlink que debieran ser contestadas por el operador con respuestas PADO y, a partir de ahí, desencadenarse todo el proceso de conexión que acabará con tu router conectado con internet y pudiendo navegar desde tu red.

Share
Última actualización el Miércoles 28 de Marzo de 2012 15:02  

Comentarios  

 
0 # Juan 16-12-2010 10:45
Por casualidad he visto tu pagina y este artículo, me lo voy a empollar, para ver si me vale con mi router 1721.

Gracias y un abrazo
Responder | Responder con una citación | Citar
 
 
0 # roberto 26-02-2012 19:33
Hola
Estuve buscando algo en google y por suerte me encontre con este articulo. Acabo de adquirir un router cisco 1811 (el que tiene solo FE y 4 puertos de SW, tambien trae un puerto para mode v.92 - el cual no pienso que me sirva para nada)
Pero al grano, el echo es que el router de mi proveedor de internet es un Clear Access AG10W, las opciones son casi iguales el el Comtrend. El hecho es que este no me permite agregar una interface atm con 8/35 pero me permite agregar 0/35 o cualquier otra que no sea 8/35. Que se puede hacer en este caso?
Gracias.
Responder | Responder con una citación | Citar
 
 
0 # admin 26-02-2012 21:57
Algunos routers no suelen permitir utilizar un par de identificadores que ya estén usados. Si el identificador 8/35 ya está en uso no se podrá definir otro adicional.

De todos modos no debiera ser necesario eliminar esa interfaz. En algunos casos (el último que he configurado por ejemplo) hay que atreverse y eliminar la conexión WAN que viene definida (y que usa la interfaz ATM anterior) y sustituirla por la nuestra configurada en modo en bridge. En el ejemplo de la página el router usado permitía tener ambas conexiones definidas simultáneamente . En el último que he configurado no era así por lo que tuve que eliminarla antes de poder proseguir. Así que, si no deja configurar la conexión bridge, lo más probables es que estemos en uno de estos casos y la única posibilidad es la de eliminar parte de la configuración existente.

Pero, como siempre, *ANTES* de hacer cambios en el router hay que realizar una copia de seguridad de la configuración del fabricante para poder volver a ella en caso necesario.
Responder | Responder con una citación | Citar
 
 
0 # MiguelPerez 28-03-2012 11:30
Hola,

He estado intentando esta configuración en un 857 pero no parece admitir más de una VLAN.
¿De verdad has podido hacero en este modelo?

Un saludo
Miguel
Responder | Responder con una citación | Citar
 
 
0 # admin 28-03-2012 14:47
Pues no.

Lo hice con un 877. Efectivamente la serie 85x no admite más de 1 vlan, que ya tiene definifda por defecto, por lo que no se puede usar para esta configuración. Disculpa por no haber tenido en cuenta este detalle.

Gracias por indicarlo. Lo corregiré en el texto.
Responder | Responder con una citación | Citar
 
 
0 # Nicolas 05-04-2013 04:30
Hola gente, quiero hacer un pequeño aporte: en la interfaz VLAN10 no es necesario el dhcp, lo puedes dejar no ip address, para la ruta por defecto tienes dos caminos: ip route 0.0.0.0/0 dialer 1 o bien dentro de la interfaz dialer: ppp ipcp route default . El comando ip mtu no suele ser efectivo, si hay que tocar la mtu usar este: ip tcp adjust-mss 1492 o un valor menor dependiendo de la perdida por encabezado ppp.
Saludos
Responder | Responder con una citación | Citar
 
 
0 # Trucos 25-02-2017 05:09
 Un game agradable de todas formas los hay mucho excelentes

Hecha un vistazo y puedes navega por mi page; Trucos: http://www.tecnygroup.org/__media__/js/netsoltrademark.php?d=trucoteca.com
Responder | Responder con una citación | Citar
 
 
0 # guias y trucos 09-04-2017 13:27
 El videogame de consolas me ha desenganado,
si bien cuenta interesantes situaciones

Chekea y ademas visita mi websiteXD guias y trucos: http://www.popteen.net/news/go.php?url=http://Trucoteca.com/
Responder | Responder con una citación | Citar
 

Escribir un comentario

El propietario de esta página no se hace responsable de las opiniones de sus lectores en los comentarios, así como puede o no estar de acuerdo con lo que en ellos se diga.

Usa el juego limpio en tus comentarios

Por favor, no realices comentarios ofensivos o insultantes. Tampoco generes comentarios con publicidad o Spam. No utilices los comentarios para 'enchufar' tu sitio. Los enlaces que pongas podrán ser eliminados. Pretendemos crear un espacio de comunicación entre el autor y los lectores.

Todos agradeceremos el correcto uso de la ortografía, pues no todos somos capaces de entender mensajes 'codificados' tipo SMS. Además te rogamos uses signos de puntuación, si puede ser, para mejorar la comprensión de tu mensaje.
No escribas sólo en mayúsculas ya que en Internet escribir con mayúsculas equivale a GRITAR y no por gritar se te va a hacer más caso sino, probablemente, al contrario.

Reserva de Edición

Nos reservamos el derecho de no incluir comentarios que sean ofensivos, desagradables, que ataquen a terceros (racistas, homófobos, etc) o que no tengan que ver con el sitio o con el tema de que se trata.
Los datos suministrados al emitir tu comentario son privados y de tu propiedad y no serán usados para ningúna acción comercial ni de otro tipo.


Código de seguridad
Refescar


Archivo

Powered by ArtTree